sasha roiz dating - Silverlight service reference not updating

I'm using Visual Studio 2008 and have a WCF client working against a WCF service.

They are both located in the same Visual Studio solution.

And in the process show how to consume a Domain Service from a Win Forms.

You can also see more examples at: Services You need: You can download the completed solution as well. The first thing we need to do is get at the data underlying service.

In the mainstream Silverlight case this is all handled for you by the implicit link between the Silverlight client and the ASP. However, in the vanilla WCF case, you get the full control.

The URL to the service is of the following format: in my case that is: App-Web-Dish View Domain Hitting that URL in the browser gives you the very familiar WCF proxy help screen: And tacking on the ?

When I select to update the service reference, the following happens: The dialog doesn't show the text "Generating \something\" (can't remember the exact wording) which I would expedct.

If I delete the service reference and add it again, the proxy is properly generated.

Create a new Win Forms project and select Add Service Reference.

Enter the URL (note discover doesn’t work for this sort of service yet)… Now, we have a service, let’s look at actually getting data out of it.

After this, update the service reference on the client app, and the changes are evident. Opened my client with Reflector and saw the service types had the change!

Tags: , ,